Issue with incoming phone calls to customer support
Incident Report for HammerTech
Resolved
Our upstream provider has resolved the issue and our phones are now working normally.
Posted Nov 23, 2017 - 11:59 AEDT
Identified
Due to an issue with an upstream telecommunications provider, our support via phone is currently unavailable. Our team is still available by email support@hammertech.com.au
Posted Nov 23, 2017 - 08:55 AEDT